欢迎使用

◆软件简介：

广外男生是广外程序员网络(前广外女生网络小组)精心制作的一款远程控制软件，是一个专业级的远程控制以及网络监控工具。

而广外男生除了具有一般普通木马应该具有的特点以外，还具备独有的特色：

1.客户端高度模仿WINDOWS资源管理器：除了全面支持访问远程服务端的文件系统，也同时支持通过对方的“网上邻居”访问对方内部网其他机器的共享资源！

2.强大的文件操作功能：可以对远程机器进行建立文件夹，整个文件夹(连子目录，文件)一次删除，支持多选的上传，下载等基本功能。同时特别支持高速远程文件查找，而且可对查找结果进行下载和删除的操作！

3.运用了"反弹端口原理"与"线程插入"技术：使用了目前流行的反弹端口的木马技术，由服务端主动连接客户端，因此在互联网上可以访问到局域网里通过 NAT 代理(透明代理)上网的电脑，轻松穿过防火墙(包括：包过滤型及代理型防火墙)。

使用广外程序员独创的“线程插入”技术。基于成功的“广外幽灵”的先进技术，服务端运行时没有进程！所有网络操作均插入到其他应用程序的进程中完成。也就是说，即使受控端安装的防火墙拥有“应用程序访问权限”的功能，也不能对广外男生的服务端进行有效的警告和拦截，使对方的防火墙形同虚设！

特别的，在同类软件中，本软件是唯一使用这种方法的。

附：同类软件原理

服务端运行后，会在本机打开一个网络端口监听客户端的连接(时刻等待着客户端的连接)，连接建立后，客户端可用这个通道向服务端发送命令并接收返回数据，即可实现远程访问。

用户反馈：

非常感谢你使用广外男生，我们的目标是将成一个能与商业软件媲美的免费软件，做成国内同类软件中最强之作。我们的进步离不开你的帮助，如果你在使用中遇到问题或者BUG，欢迎给我们来信或留言，我们将以最快的速度回复及更新，我们会做的更好！

特别声明：

本软件为免费软件，请勿将其用于非法用途。由本软件引起的任何后果均由使用者
本人承担，软件作者概不承担任何责任。
----------------------------------------------------------------------------
可以从我们的网站获取更多的信息: 暂时没有网站啊


客户端网络设置

1,客户端的网络设置页面：

由于广外男生采用反弹连接，因此是由客户端打开端口来接收服务端的连接请求，在这个页面，要重点设置的是“客户端最大连接数”以及“客户端使用端口”两个项目：

客户端最大连接数：由于使用者操作系统各有所异，如果使用WIN9X的用户本地是不能创建超过一定数目的SOCKET，因此，9X的用户请把该数字保持在30左右。WINNT，2K，XP的用户可以把该数字设大点也没有影响。

客户端使用端口：就是服务端反弹连接时使用的远程端口，最好是设置为80，这样更容易突破服务端的TCP过滤。如果您的80号端口被占用了，可以在此设置另一个使用端口。

IP地址段的过滤：有时候不想让某个网段的机器访问或只想让某个网段的机器连接您的客户段的话，可以在这里输入起止IP段。

当您完成上面的设置的时候，请按“下一步”。
下一步


客户端连接类型

2,服务端的连接类型：

广外男生目前支持2种服务端上线方式：HTTP网页连接以及静态IP连接。

HTTP网页连接：就是把客户端的IP以及开放端口写到一个HTM文件中，再把它上传到HTTP服务器上，服务端每隔一个时间就读取一次该网页的内容，从中还原客户端的IP地址和端口，再进行连接，该种连接方式适合于动态IP用户。

静态IP连接：就是指客户端的IP地址是固定的，服务端随时都可以连到该机器上，这种连接方式适合两台机器在同一局域网或客户端IP固定的用户。

当您完成上面的设置的时候，请按“下一步”。


IP通知文件制作

3，IP通知文件设置

如果在第二步的时候选择了“使用HTTP网页IP通知”的朋友，就会看到IP通知文件设置页面。

客户端IP：当前的客户端IP地址

端口：当前男生客户端正在使用的端口

加密密码：把您的IP和端口加密的密码，由于算法的需要，请使用12位以内的数字作为密码。

目标文件：就是目标生成的含有您的IP和端口的HTM文件，您不需要写上路径，程序会自动把该文件生成在男生目录下。

当您完成上面的设置的时候，请按“下一步”。


FTP服务器设置

4，FTP服务器设置：

请设置好您的FTP服务器，并把您的IP文件上传到该服务器。

FTP地址：您的FTP服务器的IP地址。

端口：一般都是21

用户名和密码：您的FTP登陆用户名和密码

发布目录：您的网页所放的目录

上传后文件：上传后的文件是否要改名，默认值是和您本地的IP文件同名。

当您完成上面的设置的时候，请按“下一步”。


服务端常规设置

1，服务端常规设置：

在该设置页面您需要进行服务端的常规设置，包括以下：

EXE文件名：您的服务端运行后拷贝到系统目录中的EXE文件名。

DLL文件名：您的服务端运行后拷贝到系统目录中的DLL文件名。

注册表启动项：服务端在注册表中的自启动项目的名称您一般可以在

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

中找到该启动项

运行标志：如果您想和您的朋友一起使用广外男生进行文件传输和数据交流的话，请选中这个选项这样广外男生的服务端就会在运行过程中在您的屏幕右下角显示一个明显的运行“i”标志并有提示文本"GWBoy is running on this machine"如下图：

在服务端的用户随时都可以用鼠标右键点取该图标进行停止男生服务端的操作如下图：

否则，男生服务端在运行的时候将不显示任何标志，也无法得知男生服务端是否在运行。

当您完成上面的设置的时候，请按“下一步”。
下一步


服务端网络设置

2，服务端网络设置：

在该设置页面您需要进行服务端的网络设置

HTTP网页形式IP通知：您的服务端将会每隔一段时间从您所设置的HTTP网页地址中读取一次您的IP地址和端口。请您在“HTTP网页地址”中设置好您的主页上的IP文件地址

静态IP：您的服务端运行后将直接连接到您设置的IP地址和端口号，这种设置适合于客户端是固定IP和服务端和客户端处于同一局域网并且IP地址相对静止的用户。

当您完成上面的设置的时候，请按“下一步”。


生成服务端文件

3，生成文件：

经过一翻设置之后，男生的服务端算是设置成功了，在该页面您将会看到一份创建日志，上面列出了该次生成的服务端的信息。

保存文件：就是您的服务端生成的路径，将要写入的文件。如果您生成之后，请不要乱点哦。

保存设置：如果您想把该次的设置保存下来，您可以选“保存设置”并存成相应的文件，下次只要导入该文件就可以轻松生成服务端了。

当您完成上面的设置的时候，请按“完成”。
上一步


文件共享

文件共享页面功能简介，工具栏如下：

对应功能依次是

新建一个文件夹
删除一个文件夹,包含里面的所有子文件夹和文件
下载一个或多个文件
上传一个或多个文件
删除一个或多个文件
远程运行选定的文件或命令支持参数和多种显示模式
远程 查找文件并返回结果,可以对结果进行下载和删除的操作。


远程注册表操作

远程注册表操作，和使用本地注册表编辑器的效果差不多。

可以修改键名，新建，删除和修改键值。

注册表页面功能简介，基本上和以前广外女生没有什么不同，请查以前的资料：）


服务与进程管理

进程与服务页面功能简介，工具栏如下：

获取对方主机的信息，包括系统类型，版本等
向对方机器发送消息，由于男生不是一个聊天程序，所以对方只能收不能回！
杀死一个进程或退出一个线程
窗口操作(隐藏等)
启动一个停止的服务(仅对NT，2000，XP有效)
继续运行或暂停一个服务(仅对NT，2000，XP有效)
停止一个正在运行的服务(仅对NT，2000，XP有效)


图象抓取

<%@LANGUAGE="VBSCRIPT" CODEPAGE="936"%> 图象抓取

屏幕图象截取：

可以抓取远程机器的桌面情况。并可以保存为JPG图象文件。


问与答

 Q & A:

问: 我能否在局域网（网吧）中控制该局域网以外的计算机？
答: 很抱歉，所有反弹连接的远程控制软件均不能实现此操作。

问: 如何可以卸载广外男生的服务端？
答: 一般来说手动卸载比较复杂，所以我们建议您使用广外男生自带的卸载功能来卸载服务端，方法是：当服务端连上您的客户端之后，到“进程与服务”的页面，点击工具栏上最右边天使的图标，就可以卸载男生的服务端。

问: 线程插入到底有什么用？
答: 该技术主要是用于穿过用“应用程序访问权限”的防火墙。有了这种技术，广外男生所有的网络操作都会在其他程序的进程中完成，自身并不访问网络，因此防火墙根本不能对其进行有效的警告。您以后都不需要为服务端的文件名字而头痛了：）

问: 我放在网页上的IP地址是否会很容易被人知道？
答: 不会，您的IP，端口信息都是经过多次加密，虽然密码是数字，用穷尽方法来破解的话得到的结果是千千万万的，每一个都有可能：）

问: 为什么最好的使用端口是80？
答: 如果对方设置了TCP/IP过滤的话，反弹连接是不能访问被过滤的端口的，而80号端口有较高机会被允许访问，因此最好使用80作为客户端的端口。

问: 是否有可能做到断点续传？
答: 因为这个是BETA版本，我们主要是先把程序的主框架发布出来，断点续传等功能将在后期的版本我们会继续有所改进。

问: 我有其他问题想发问，有什么办法可以联系你们呢？
答: 现在网站还没有搞好，所以有什么问题或BUG报告请您发到下面的信箱：

服务端问题：synth(at)etang.com
客户端问题：inguram(at)etang.com